0
Не ошибка

Конфликт версий jQuery

Георгий 2 года назад обновлен Пользователь 57981 10 месяцев назад 7

Собственно сабж. В проекте используется версия - 3.2.1. Предложенная вами - 1.10.2. Собственно, если отключить 3.2.1, то подсказки начинают работать, но отваливается другой функционал сайта.

интерфейс: jquery-плагин сервис: подсказки

Ответ

Ответ
На рассмотрении

Плагин подсказок работает со всеми версиями jQuery старше 1.10. Так что спокойно используйте 3.2.1

ХОРОШО, МНЕ ПОНРАВИЛОСЬ
Оценка удовлетворенности от Георгий 2 года назад

Предложенная вами - 1.10.2. Единицу пропустил :)

Ответ
На рассмотрении

Плагин подсказок работает со всеми версиями jQuery старше 1.10. Так что спокойно используйте 3.2.1

Доброго времени, Антон! Собственно, я использую версию 3.2.1, но с ней подсказки не работают, мол suggestions is not a function...

В целом, я попробовал ваш сервис "Стандартизация", ооочень крутой инструмент :). И как оказалось, он мне больше подходит. Поэтому, тему можно закрывать. А мой вопрос, оставить разве что потестить с 3.2.1 с вашей стороны.

Спасибо ツ Плагин работает с версией 3.2.1. Ошибка «suggestions is not a function» указывает на то, что проблема в чём-то другом (например, скрипт подсказок подключен до jquery). Если для вас проблема актуальна — дайте ссылку на проблемную страницу и я посмотрю, в чём может быть дело.

У меня jquery 1.8.3 хочу использовать плагин, но увы не работает, и jquery поменять не могу

есть ли возможность использовать древний  jquery?

P.S. вопрос не актуален, решил проблему средствами jquery $.noConflict(true);

Сервис поддержки клиентов работает на платформе UserEcho